PHP, which is an acronym for PHP: Hypertext Preprocessor, is one of the most popular general-purpose server-side coding languages that are available out there. Any website or Internet app built with PHP will run on a given server on the condition that a PHP module is installed, which makes the language truly universal and it is small wonder that there are actually a couple of million web servers that support it and hundreds of millions of PHP sites hosted on them. PHP is preferred over HTML owing to the fact that it permits you to build a dynamic site with tons of different features. A PHP-based community web portal, for instance, will display unique content to each visitor despite the fact that the page URL will stay the same. In contrast, HTML websites are static and the content on the pages can be modified only manually. Just like any other piece of software, PHP has different versions and the version that was used whilst creating a specific website must be present on the web server in order for the site to behave properly.
PHP 4 and PHP 5 Support in Hosting
With our hosting, you will be able to select which version of PHP will be enabled for your shared web hosting account, as multiple versions are available on our servers. With just one click of the mouse, you will be able to switch between PHP 4, 5.2, 5.3, 5.4 and 5.5 and whenever a new version is published in the future, we will include it in the Hepsia Control Panel without removing the older ones. Thus, you’ll be able to host all the sites that you have developed through the years. In contrast to a lot of other hosting vendors, we won’t compel you to update such sites, because a script may be out of date, but this doesn’t necessarily mean that it’s vulnerable since you may have implemented modifications to its source code to plug security loopholes. For your convenience’s sake, you’ll even be able to set a different PHP version for each individual site hosted in your hosting account.
PHP 4 and PHP 5 Support in Semi-dedicated Hosting
Even in case your sites were created with an earlier version of PHP, you will be able to host them in a semi-dedicated server account from us, as we support several versions running at the same time on our semi-dedicated servers and each one of them can be enabled for your account with just one click through our custom-developed Hepsia Control Panel. Aside from the latest PHP 5.5 and PHP 5.4, we also offer 5.2, 5.3 and the older PHP 4. The latter has already been dropped by most web hosting suppliers, but we strongly reckon that you shouldn’t be compelled to modify a website that took several years to develop, since older scripting language syntax does not necessarily suggest safety vulnerabilities. Quite the opposite, a well-maintained website using PHP 4 can be more reliable than a badly maintained one using PHP 5. For the sake of your convenience, we will also offer you the opportunity to specify a different version for each single website within the account.